You are on page 1of 48

Barra de herramientas........................................................................................................

2
barra de herramientas estándar..........................................................................................2
La mayor parte de los botones de Excel en la Barra Estándar, son verdaderamente
estándar. Verá a los mismos botones en otros programas de Microsoft, como por
ejemplo en Word. No obstante esto, hay algunas diferencias en la manera en que los
botones funcionan, lo que podría causar problemas. ......................................................2
Barra de herramientas formato..........................................................................................2
Los objetos de dibujo incluyen Autoformas...................................................................2
Tipos de datos y formatos. Formato condicional..............................................................3
Formato condicional..........................................................................................................3
Formulas y funciones.........................................................................................................8
Imágenes y gráficos.........................................................................................................13
........................................................................................................................................14
Vincular e incrustar documentos.....................................................................................22
Bases de datos..................................................................................................................26
Listas................................................................................................................................31
Agregar viñetas o numeración al texto existente...................................................31
Agregar un formato de lista numerada o con viñetas al texto existente.................32
Crear una lista con viñetas o lista numerada mientras escribe...............................33
Esquema listas numeradas y las listas con viñetas de esquema.............................34
Formularios......................................................................................................................37
Tablas y gráficos dinámicos............................................................................................40
Crear una tabla Dinámica................................................................................................40
Rango de Datos................................................................................................................41
Macros.............................................................................................................................42
Seleccionando tipos de gráfico: podemos elegir el tipo de gráfico, y elegimos el tipo
Estándar. Tipo de gráfico Áreas obtendremos:...............................................................42
Ejemplo de usos VBA.....................................................................................................43
Barra de herramientas

barra de herramientas estándar

La mayor parte de los botones de Excel en la Barra Estándar, son


verdaderamente estándar. Verá a los mismos botones en otros programas
de Microsoft, como por ejemplo en Word. No obstante esto, hay algunas
diferencias en la manera en que los botones funcionan, lo que podría
causar problemas.

Barra de herramientas formato

Con la Barra de Formato puede cambiar el aspecto de su hoja de cálculo y de


sus números. Como los números representan tanto, dentro de todo lo que
contiene una hoja de cálculo, Excel dispone de varios botones para dar formato
a los mismos. Los otros botones para dar formato funcionan como se espera.

Los comandos de formato se aplican generalmente a toda la celda. También


puede dar formato solamente a una parte del texto contenido dentro de la celda
(fuente, tamaño de fuente, estilos, color), pero en cambio, los formatos de
números, alineamientos y sangrías solo se aplican a la celda íntegra. Los
alineamientos y sangrías son aplicados solo dentro de la celda y no a través de
toda la página u hoja de cálculo.

Los objetos de dibujo incluyen Autoformas.


Para mostrar una barra de herramientas, haga clic en Personalizar en el menú
Herramientas y, a continuación, haga clic en la ficha Barras de herramientas.
Tipos de datos y formatos. Formato condicional

Formato condicional

El formato condicional se utiliza para aplicar unas características de


formato a determinadas celdas de la hoja de cálculo, dependiendo de
que se cumplan determinadas condiciones.

Por ejemplo, una celda contiene una fórmula que calcula la varianza
entre las ventas pronosticadas y las ventas reales y se quiere aplicar
un sombreado de color verde a las celdas si las ventas reales
sobrepasan a las ventas pronosticadas y un sombreado de color rojo si
las ventas reales son menores que las ventas pronosticadas.

Los formatos condicionales seguirán aplicándose a las celdas hasta


que se quiten, incluso aunque no se cumpla ninguna de las
condiciones y no se muestren los formatos de celda especificados.

Para aplicar los formatos condicionales se siguen los siguientes pasos.

1.- Seleccionar las celdas a las que se quiere dar formato.

2.- Pinchar en el menú Formato la opción Formato condicional.


Aparecerá la siguiente ventana, donde debemos establecer la
condición para aplicar el formato deseado.
3.- Para establecer la condición se puede realizar de 2 formas:

a.- Valor de la celda. En este caso utilizamos los valores de las celdas
seleccionadas como el criterio de formato, elegimos la frase de
comparación, que por defecto es entre, e introducimos un valor en el
cuadro correspondiente. Puede introducirse un valor constante o una
fórmula; debe incluirse un signo igual (=) delante de la misma.

b.- Fórmula. Para evaluar datos o una condición que no sean los
valores de las celdas seleccionadas. En este caso la figura que
aparece es la siguiente.

En el cuadro de la derecha escribimos la fórmula que debe evaluarse


contra un valor lógico VERDADERO o FALSO.

4.- Una vez establecida la condición, pulsamos el botón Formato y


seleccionamos el estilo de fuente, el color, el subrayado, los bordes o
la trama que queramos aplicar.
El formato seleccionado solamente se aplicará si el valor de la celda
cumple la condición o si la fórmula devuelve un valor VERDADERO.

6.- Para añadir otra condición, pulsamos el botón Agregar y repetimos


los pasos del 3 al 5.

Pueden especificarse tres condiciones como máximo. Si se


especifican varias condiciones y más de una de ellas es verdadera,
solamente se aplicará los formatos de la primera condición que sea
verdadera. Si ninguna de las condiciones que se han especificado es
verdadera, las celdas conservarán los formatos existentes. Pueden
utilizarse los formatos existentes para identificar una cuarta condición.

Para buscar celdas que tengan formatos condicionales

1.- Para buscar las celdas que tengan formatos condicionales


específicos, haga clic en una celda que cumpla el criterio condicional y
los formatos que desee localizar. Para buscar todas las celdas de la
hoja de cálculo que tengan formatos condicionales, haga clic en
cualquier celda.

2.- En el menú Edición, seleccionamos la opción Ir a y pulsamos el


botón Especial...

4.- Seleccionamos la opción Celdas con formatos condicionales y


dependiendo de si queremos buscar todas las celdas con formato
condicional o bien las que tienen formatos condicionales idénticos a la
celda que tenemos seleccionada seleccionamos la opción Todos o
Iguales a celda activa, respectivamente.
Ejemplo:

En la siguiente hoja de cálculo se desea que la celda C2, donde se calcula la


diferencia entre A2 y B2, tenga el siguiente formato

- negrita y cursiva si el valor está comprendido entre -2 y 2.

- sombreado de color rojo si el minuendo es menor que el sustraendo.

Solución

En la celda C2 introducimos

=A2-B2

Para aplicar el formato condicional establecemos las siguientes


condiciones.
Formulas y funciones
Las fórmulas y las funciones vienen del Excel. Excel es una hoja de
cálculo que utilizamos con una serie de fórmulas para evitar tener que
recalcular por cada cambio que hacemos.
Introducir Fórmulas y Funciones
Una función es unas fórmulas predefinidas por Excel que opera con
uno o más valores y devuelve unos resultados que aparecerán
directamente en la celda o será utilizado para calcular la fórmula que la
contiene.
A continuación pondremos algunas reglas que debemos cumplir al
trabajar con Excel.
1. si la función va al comienzo de una fórmula debe empezar por el
signo =.
2. los argumentos o valores de entrada van siempre entre
paréntesis.
3. los argumentos pueden ser valores constantes (número o texto),
fórmulas o funciones.
4. los argumentos deben de separarse por un punto y coma.
Aquí mostramos como funciona con un ejemplo.
=SUMA (A1:C8)
Tenemos la función SUMA () que devuelve como resultado la suma
de sus argumentos. El operador nos identifica un rango de celdas,
así A1:C8 indica todas las celdas incluidas entre la celda A1 y C8,
así la función anterior sería equivalente a:
=A1+A2+A3+A4+A5+A6+A7+A8+B1+B2+B3+B4+B5+B6+B7+B8+
C1+C2+C3+C4+C5+C6+C7+C8
Insertar Función con el Asistente
Si queremos introducir una función en una celda:
Situarse en la celda donde queremos introducir la función,
desplegar el menú INSERTAR. Después debemos elegir la
opción FUNCIÓN.
También podemos hacer clic en el botón de la barra de
fórmulas.

-Aparecerá el cuadro de diálogo Insertar Función.

Debajo de las barras de fórmulas aparecerá el cuadro de diálogo


Argumentos de Función, donde nos pide introducir los argumentos de
la función: este cuadro variará según la función que hayamos elegido.
En este caso se eligió la función SUMA ().
Referencias relativas y absolutas. Copiar y mover celdas
Una fórmula puede hacer referencia al contenido de una celda
que está en otra hoja de su columna y el número de su fila.
Referencias Relativas
Las referencias relativas son: columna y fila. Para referirse a
una celda que está en otra hoja dentro del mismo libro, la
referencia irá precedida del nombre de la hoja y un signo de
exclamación (!)
Copiar y Mover celdas
La información del área de trabajo puede copiarse y pegarse en
otros sitios, o también moverse. Las opciones son las típicas:
Cortar, Copiar, Pegar. A ellas tendríamos que añadir Mover o
copiar hoja, también en el menú Edición, que permite copiar o
mover una hoja entera a otra ubicación.
Referencias absolutas
Las referencias absolutas son una manera de referirse a una
celda en una fórmula de modo que, aunque la fórmula cambie
de ubicación, la referencia a la celda no se altere. La parte a
fijar es (fila, columna o ambas) y precede del signo $.
Funciones disponible en Excel
A continuación pondremos algunas funciones que son
principales:
1. Financieras. Realizan cálculos relacionados con intereses,
inversiones, pagos y otros temas relacionados con las finanzas.
2. Fecha y Hora. Sirven para realizar todo tipo de operaciones con
fechas, y también para hacer transformaciones entre tipo
fecha/hora y otros.
3. Matemáticas y Trigonométricas. Todas las funciones que
realizan cálculos matemáticos y trigonométricos.
4. Estadísticas. Funciones estadísticas como la media, la mediana,
etcétera.
5. Búsqueda y Referencia. Funciones para realizar búsquedas en
el documento y también para trabajar con referencias de todo
tipo.
6. Base de Datos. Funciones para trabajar con el contenido de la
hoja de cálculo como si fuera una base de datos.
7. Texto. Realizan operaciones con cadenas de texto, como
comparaciones, extracción de una parte del texto, calcular su
longitud, conversiones y transformaciones.
8. Lógicas. Funciones que se corresponden con las operaciones
lógicas típicas: SÍ, NO, O, Y, VERDADERO, FALSO.
9. Información. Devuelven información sobre el contenido o el
formato de una o varias celdas. También incluye algunas
funciones de conversión.
10. Definidas por el usuario. El usuario puede definir sus propias
funciones, utilizando métodos y lenguajes externos, o incluidos en la propia
aplicación.
Imágenes y gráficos
Inserción de imágenes
1. Imágenes prediseñadas. Permite insertar imágenes de la
galería de Microsoft Office. Se abrirá un asistente en la parte
derecha de la pantalla para poder escoger la colección donde
buscar, el tipo de imagen, realizar búsquedas por contenido.
2. Desde archivo. Inserta imágenes externas desde un
cuadro de diálogo de búsqueda y selección.
3. Desde escáner o cámara. Necesita de una conexión con
un proveedor externo de imágenes, como una cámara de fotos
o un escáner. Puede ser necesario disponer de la interfaz
TWAIN, software que se utiliza para este tipo de capturas, pero
con las conexiones USB actuales pueden grabarse el fichero en
disco y posteriormente insertarse como cualquier otra imagen.
4. Autoformas. Permite insertar líneas, figuras geométricas,
flechas y otras formas básicas, al seleccionar esta opción se
abre una ventana en la cual se muestran las diferentes
categorías de autoformas que están disponible. Haciendo clic
en cada categoría se visualizan las imágenes que contiene, y al
seleccionar una imagen el cursor del ratón se convierte en una
sencilla herramienta de dibujo.
5. WordArt. Permite la inserción de texto en un formato más
gráfico y artístico. Dispone de distintos tipos que se muestran al
seleccionar esta opción.
6. Organigrama. Facilita la inserción de un organigrama o
diagrama jerárquico sin tener que utilizar las autoformas
correspondientes.

7. Símbolo. Permite insertar algún símbolo especial como


letras de alfabetos distintos, abreviaturas, símbolos de
moneda, etcétera.
8. Diagrama. Una pequeña galería con diagramas
predefinidos.

Gráficos
Grafico entre Estándar o Personalizado
Tipo de grafico: Se debe seleccionar entre una lista de
ejemplos.

Se puede observar el ejemplo de cada tipo de grafico con los


valores que se quiere graficar, pulsando y manteniendo pulsado
el botón que se encuentra en el extremo inferior derecho con el
nombre Presionar para ver muestra.
Tipos de gráficos:
1. Barras / Columnas
Este grafico sirve para comparar datos entre diferentes
segmentos (sectores, empresas, periodos de tiempo...).

2. Líneas Ayudan a ver la evolución de los datos. Por lo


general se usan para mostrar un mismo tipo de dato y su
evolución (valor de la acción y el tiempo, numero de
ventas y precio).
A continuación pondremos algunos gráficos que suelen ser
utilizados en Excel.

Microsoft Graph
Para poder insertar un gráfico, previamente necesitamos tener
creada una hoja Excel con los datos que queramos incrustar en
el grafico.

Los gráficos los podemos insertar desde la barra de


herramientas:

O bien lo podemos realizar desde el menú Insertar Gráficos


Como ejemplo podemos crear una hoja en Excel y ver el
resultado, ya que dentro de estas opciones de gráficos existe
una amplia gama de variedades.
Este sería el resultado que obtendríamos insertando un gráfico
del total de ventas de una empresa cualquiera. Los pasos que
debemos realizar se muestran a continuación:

Introducimos los datos sobre ventas.

Calculamos el total de ingresos.


Pinchamos en la Barra de herramientas Insertar gráfico.

En ella elegiremos el gráfico que deseamos.


A continuación nos aparecerá otra imagen que nos indica el

resultado que aparecerá en el gráfico, que en este caso es el


resultado total de los ingresos por venta mensual.

En este cuadro elegiremos la denominación del eje de


coordenadas.
Y por último nos solicitará la ubicación del gráfico:

Seleccionamos la opción de Finalizar y nos aparecerá en la hoja


de cálculo el resultado.

Vincular e incrustar documentos


Vincular Documentos
La vinculación entre documentos Excel puede realizarse de dos
maneras diferentes.
1. Desde La Barra de Fórmulas. Al incluir en una fórmula el
contenido de una celda vinculada, tenemos que teclear su
contenido incluyendo el libro entre corchetes seguido de la hoja,
un signo de cierre de exclamación y para terminar la columna y
fila de celda.
C:\TRABAJO\ [Prueba.xls] Hoja 1 ¡B12
Carpeta original Documento Libro Celda
- Copiando y pegando las celdas, y en opciones de
pegado seleccionando Vincular.
2. Si queremos vincular un documento que no sea
precisamente con Excel, debemos insertarlo como un objeto
externo, mediante el menú Insertar > Objeto. Mediante esta
opción mostramos una ventana con diferentes tipos de objetos
que pueden incluirse en la hoja de cálculo.
Incrustar Documentos
La incrustación, crea una copia del archivo original y no un
vínculo. El objeto incrustado puede modificarse sin que los
cambios afecten al original; el objetivo incrustado se guarda
junto al documento Excel aumentado más su tamaño. Excluye
la posibilidad de visualizar los cambios en el documento origen
si es necesario.
La incrustación se realiza de la misma manera que la
vinculación, pero sin marcar la opción Vincular. Si marcamos
Mostrar como icono, solo veremos una especie de acceso
directo, en forma de icono, al documento incrustado. Si
hacemos doble clic en este mismo icono finalmente el archivo
se abrirá.
Bases de datos
Una base de datos nos permite guardar grandes cantidades de
información de forma organizada para que luego podamos
encontrar y utilizar fácilmente.
Tipos de campos de una tabla

1. Texto. Permite introducir texto o una combinación de


letras y números. La longitud máxima es de 50
caracteres.
2. Número. Permite guardar, en el campo correspondiente,
valores numéricos.
3. Autonumérico. Es un tipo numérico en el que, para cada
nuevo registro, aparece escrito el siguiente valor
numérico de forma automática.
4. Fecha/Hora. Los campos del tipo Fecha/Hora guardan
datos relacionados en el formato adecuado.
5. Moneda. Cuando en el campo se deban guardar valores
numéricos relacionados con monedas, por ejemplo, el dólar ($)
o el euro (€), se seleccionará este tipo.
6. Sí/No. Este campo admite datos que respondan a
verdadero/falso o sí/no. Este campo se usará cuando en una
columna o campo el dato que vayamos a guardar solo pueda
contener estos dos valores.
7. Memo. Permite al usuario de la tabla introducir un texto de
mayor extensión en comparación con el tipo de campo Texto.
Relaciones
En las bases de datos la información se distribuye en varia
tablas que están interconectadas entre sí. También nos
conviene tener en cuenta que las relaciones pueden ser de
diferentes tipos:
Access permite definir tres:
1. de uno a muchos
2. de muchos a muchos
3. de uno a uno

Operaciones con tablas


Es necesario realizar tareas de mantenimiento o tratamiento de
tablas al efectuar estas mismas tareas y se pueden ocasionar
daños irreparables en el contenido de las tablas.
Será imprescindible contar con la posibilidad de realizar ciertas
operaciones que serán de utilidad para conservar o recuperar el
contenido o diseño de la tabla.
Cambiar el nombre de una tabla
Tendremos que seleccionar primero el nombre de la tabla y, a
continuación, elegir la opción Edición>Cambiar nombre o bien
pulsar la tecla F2.
Copiar y Borrar una tabla
1. Debemos seleccionar el nombre de la tabla que
deseamos copiar desde el Panel de control Access.
2. elegir la opción Edición>Copiar.
3. Seleccionamos la opción Edición>Pegar, de manera que
aparecerá un cuadro de diálogo en el cual se deberá escribir un
nuevo nombre para la copia de la tabla.
4. ofrece la posibilidad de copiar los datos de la tabla original a
la tabla que nos indica el usuario, añadiendo los registros de la
tabla original siempre y cuando sea la misma. Las dos primeras
opciones permiten copiar solamente la estructura y los datos.
Imprimir una tabla.
Se puede realizar a través de dos ventanas diferentes:
1. la ventana inicial de Access
2. la ventana en la que se muestran los registros de la tabla.
Se deberá ejecutar el comando Archivo/Imprimir, lo cual
aparecerá el cuadro de diálogo Imprimir.
Intervalo de impresión.
Sirve para determinar si se imprime toda la tabla, algunos de los
registros o parte de las páginas.
A la hora de imprimir, el usuario dispone de dos posibilidades.
1. dirigirse a Copias y señalar el número de copias de cada
página para hacer el clic en el botón Aceptar y obtener las
copias impresas deseadas.
2. hacer clic en el botón Imprimir, dando lugar a la impresión de
la tabla sin que aparezca el cuadro de diálogo Imprimir.
Vista preliminar
Debemos seleccionar la opción Archivo/Vista preliminar. Una
vez ejecutada esta opción, aparecerá una ventana en la que el
usuario podrá visualizar los datos de la tabla con la apariencia
final que tendremos una vez impresos en papel.
Listas

Agregar viñetas o numeración al texto existente


Para agregar viñetas o numeración a una lista de elementos de
texto existente, sigue estos pasos:

1. Inicie Word y, a continuación, abre un documento.


2. Selecciona los elementos de lista que deseas agregar
viñetas o numeración.
3. En la barra de herramientas formato , sigue uno de los
siguientes:

- Hacer clic en el botón viñetas si deseas agregar viñetas.

- Hacer clic en el botón numeración si deseas agregar


numeración.
Agregar un formato de lista numerada o con viñetas al texto
existente

1. Inicia Word y, a continuación, abre un documento.


2. Selecciona los elementos de lista que deseas agregar
viñetas o numeración.
3. En el menú formato , hacer clic en numeración y viñetas y,
a continuación, sigue uno de los siguientes:

- Hacer clic en la ficha si deseas agregar viñetas.

- Hacer clic en la ficha números si deseas agregar numeración.

4. Hacer clic en el formato de lista con viñetas o numerada


que desee y, a continuación, haga clic en Aceptar.

El formato con viñetas o numerado se agrega a los elementos


de la lista.
Crear una lista con viñetas o lista numerada mientras escribe

1. Inicia Word y, a continuación, abre un documento.


2. Realiza una de las acciones siguientes, según la versión de
Word:

- En Word 2000, hacer clic en Auto corrección en el menú


Herramientas y hacer clic en la ficha Auto formato mientras
escribe.

- En Word 2002, hacer clic en Opciones de Auto corrección en


el menú Herramientas y hacer clic en la ficha Auto formato
mientras escribe.

3. En Aplicar mientras escribe , siga uno o ambos de los


siguientes y, a continuación, hacer clic en Aceptar :

- Hacer clic para activar la casilla de verificación listas


automáticas con viñetas.

- Hacer clic para activar la casilla de verificación listas


automáticas con números.

4. Sigue uno de los siguientes:

- si deseas iniciar una lista numerada.

- si deseas iniciar una lista con viñetas.

5. Presiona la tecla Barra Espaciadora.


6. Escribe el texto y, a continuación, presiona Entrar.
7. Repite el paso 6 para crear elementos de lista adicionales.
8. Para finalizar la lista, presiona Entrar dos veces.

Esquema listas numeradas y las listas con viñetas de esquema

Crear una lista numerada de esquema


Para crear una lista numerada de esquema, sigue estos pasos:

1. Inicia Word y, a continuación, abre un documento.


2. En el menú formato, hacer clic en numeración y viñetas y, a
continuación, hacer clic en la ficha Esquema numerado.
3. Selecciona cualquier estilo de lista en la fila superior y, a
continuación, hacer clic en Aceptar.
4. Escribe el texto de lista; no olvides presionar Entrar
después de cada elemento.
5. Para mover un elemento de esquema numerado al nivel
que deseas, sigue uno de los siguientes:
- Para bajar un elemento a un nivel inferior, selecciona el elemento
y, a continuación, hacer clic en Aumentar sangría.

- Para aumentar un elemento a un nivel superior, selecciona el


elemento y hacer clic en Reducir sangría.

El elemento se mueve al nivel que especifique y el nivel de


numeración adecuado se inserta al principio de la línea.

Crear una lista con viñetas de esquema


Para crear una lista con viñetas de esquema, sigue estos pasos:
1. Inicia Word y, a continuación, abre un documento.
2. En el menú formato, hacer clic en numeración y viñetas y, a
continuación, hacer clic en la ficha Esquema numerado.
3. Selecciona cualquier estilo de lista en la fila superior y, a
continuación, hacer clic en Personalizar.
4. En el cuadro nivel, hacer clic en 1.
5. En el cuadro estilo de número, selecciona una viñeta
existente o hacer clic en Nueva viñeta para seleccionar la viñeta
que deseas.
6. Repite los pasos 4 y 5 para agregar niveles adicionales a la
lista. Selecciona un nivel diferente y una viñeta diferente para
cada nivel de la lista.
7. Hacer clic en Aceptar.

Aparece una viñeta para el primer nivel de la lista.


8. Escribe el texto de lista; no olvides presione Entrar después
de cada elemento.
Las viñetas se insertan automáticamente al principio de cada
línea del primer nivel.
9. Para mover un elemento con viñeta al nivel que deseas,
realiza una de las acciones siguientes:

- Para bajar un elemento a un nivel inferior, hacer clic en el


elemento y, a continuación, hacer clic en Aumentar sangría.

- Para aumentar un elemento a un nivel superior, hacer clic en el


elemento y hacer clic en Reducir sangría.
Formularios
Los formularios de pueden utilizar para introducir, modificar, ver e imprimir
datos de una manera sencilla y sin conocimientos de bases de datos por parte
del usuario. El formulario se podrá usar para realizar todas las funciones
necesarias.

Como crear un Formulario

Campos de formulario con Texto:

- Texto normal: Se deberá usar un campo de formulario tipo


texto normal cuando se pueda introducir cualquier tipo de
entrada: texto, números e incluso símbolos.

- Número: Se utilizará este tipo de campo cuando la entrada de


datos sea numérica. Si utilizamos este tipo de campo numérico,
estamos obligando al usuario a introducir sólo datos numéricos,
si esto no es así, Word dará un error de que se necesita un
número válido.

- Fecha: Se utilizará este campo cuando se necesite un formato


de fecha.

- Fecha actual y Hora actual: Este dato lo suministrará el propio


sistema. Este campo se actualizara cada vez que se haga la
presentación preliminar del documento ó se imprima el
documento con la opción de "Actualizar campos" activada.

- Cálculo: Utilizar este campo cuando se necesite efectuar algún


cálculo de otros campos de formulario tipo numérico.

- Campos de formulario con casilla de selección:

- Este tipo de campos piden a los usuarios que especifiquen un


SÍ o NO como respuesta.

- Campos de formulario con lista desplegable:

- Este tipo de campos ofrecen una serie de opciones para que el


usuario seleccione una de ellas.
Tablas y gráficos dinámicos
Una tabla dinámica en Excel permite hacer resúmenes de una
base de datos. Para que su uso este justificado, la cantidad de
información con la que se trabaja en la tabla debe ser
relativamente grande. A continuación se mostrará una tabla en
la que vienen los principios básicos de las Tablas Dinámicas en
Excel.

Crear una tabla Dinámica


- con el cursor en cualquier celda de la tabla anterior, abrir
la opción Menú-Datos-Informe de tablas y gráficos
dinámicos.
- Seleccionar las opciones del gráfico siguiente.
Rango de Datos

Ubicación de la Tabla
Macros
Haciendo clic con el botón derecho del ratón y seleccionando la
opción Gráfico Dinámico, aparecerá un gráfico en columna.
Haciendo clic con el botón derecho, se produce la siguiente
imagen.

Seleccionando tipos de gráfico: podemos elegir el tipo de


gráfico, y elegimos el tipo Estándar. Tipo de gráfico Áreas
obtendremos:
Ejemplo de usos VBA

Imagen 1 Imagen 2

Para abrir un Visual Basic le damos a Ver -Barra de


Herramientas-Visual Basic. Después nos aparecerá un pequeño
recuadro y entre dicho cuadro nos aparecerá el menú de Visual
Basic.
Con el Visual Basic podemos grabar y ejecutar macros, abrir el
editor de Visual Basic y el cuadro de controles.
Aquí se muestra un pequeño ejemplo.
Ejercicio 1- Artículos y Precios

A la vista de los datos que se presentan en el siguiente formato de factura,


obtener:
1. El precio bruto, neto y con IVA para cada producto.
2. El importe bruto, neto y con IVA en la factura.

ARTICULO PRECIO CANTIDAD BRUTO NETO TOTAL


Impresora 29900 2 59800 9568 69368
CPU Pentium II 110000 4 440000 70400 510400
Monitor color 52000 4 208000 33280 241280
Ratón 600 4 2400 384 2784
Teclado 1500 4 6000 960 6960

IVA= 16% Total bruto Total neto TOTAL


716200 114592 830792

Ejercicio 2- Ciudades y Cementos

Diseñar una hoja de cálculo que muestre los consumos de cemento de las
provincias andaluzas durante los años 1999 y 2000. Una vez que tengamos la
hoja, generar los siguientes gráficos:
1. Gráficos de columnas que compare de cada provincia en cada año (no
incluir los totales)
2. Gráfico de columnas apiladas que muestre el consumo total de cemento
en cada provincia durante los dos años.
3. Gráfico combinado que muestre comparativamente el consumo de cada
provincia por años (en columnas) y los consumos medios (en filas).
Consumo de cemento en Andalucía

Tn 1994 Tn 1995 TOTAL Medias


Almería 472825 469450 942275
Cádiz 635758 477031
Córdoba 391751 442085
Granada 517147 517489
Huelva 277792 263190
Jaén 344378 295516
Málaga 139051 1021136
Sevilla 1413714 1146294
Ejercicio 3- Resultados por Productos

1. Completar los datos que faltan en la hoja


2. Confeccionar un gráfico en el que se compare ventas netas y margen
bruto de cada producto.

RESULTADOS POR
PRODUCTOS PROD.A PROD.B TOTAL
1. Ventas 50 55 105
2. Devoluciones 5,5 7,2 12,7
3. VENTAS NETAS (1-2) 44,5 47,8 92,3
4. Amortizaciones 10,5 5 15,5
5. Costes de producción 9 7,3 16,3
6. MARGEN BRUTO (3-4-5) 25 35,5 60,5

Ejercicio 4- Sueldos y Pagas

A la vista de la nómina de IRPF Asociados


1. Calcular las columnas vacías, sabiendo que la retención practicada a
priori sobre el sueldo bruto es del 15% en concepto de IRPF y 2% en
concepto de Seguridad Social (SS).
2. Calcular la paga mensual, sabiendo que son quince (15) pagas,
distribuidas a lo largo del año.
3. Confeccionar un gráfico donde se compare la retención de IRPF para
cada uno de los Empleados.

SUELDO SUELDO
NOMBRE BRUTO SS IRPF NETO
Ruiz 1.200.000 240 1800 1.197
Sandoval 1.250.000 250 1875 1.247
Antúnez 1.320.000 264 1980 1.317
Melendo 1.100.000 220 1650 1.098
Morales 2.300.000 460 3450 2.296
Izquierdo 2.340.000 468 3510 2.336
Rovira 3.400.000 680 5100 3.394
TOTALES 12.910.000 2.582 19.365 12.888

IRPF 15%
seguridad social 2%
100

Ejercicio 5- Vendedores y Comisiones

Mantenemos una tabla con los datos correspondientes a las ventas y sueldos
base de un grupo de comerciales, así como las comisiones establecidas en la
empresa. Se desea elaborar un informe completo en los datos pendientes.

VENDEDOR VENTAS COMISION BASE TOTAL % VENDEDOR


Martín Peña 4.600.000 920 90.000 90.920 8%
González Suevo 6.000.000 1200 90.000 91.200 8%
Arana Higueras 3.900.000 780 90.000 90.780 8%
Sierra Garzón 7.600.000 1520 90.000 91.520 8%
Álvarez Justo 8.250.000 1650 90.000 91.650 8%
Carnicer Heras 3.500.000 700 90.000 90.700 8%
López Vara 5.350.000 1070 90.000 91.070 8%
Hidalgo Jimena 4.200.000 840 90.000 90.840 8%
Vargas Cayo 7.900.000 1580 90.000 91.580 8%
Hoffman Kocinski 6.780.000 1356 90.000 91.356 8%
Lisado Hoyos 4.690.000 938 90.000 90.938 8%
Gracia Fraile 3.000.000 600 90.000 90.600 8%
Castro Suárez 3.100.000 620 90.000 90.620 8%
TOTALES 68.870.000 13.774 1.170.000 1.183.774 100

comisión 2%
100

Ejercicio 6- Actividad
La empresa XY pretende realizar un estudio estadístico de su fuerza de ventas
en toda España.
Para ello, dispone de la siguiente información grabada en la hoja de cálculo:

VTAS
VENDEDOR ZONA VENTAS BONUS COMISION REMUNERACION NETAS
Pérez Norte 300000 7% 14% 630 299370
López Sur 150000 4% 11% 225 149775
Gómez Norte 360000 7% 14% 756 359244
Pérez Sur 200000 5% 12% 340 199660
López Norte 150000 4% 11% 225 149775
Gómez Sur 250000 6% 13% 475 249525
Pérez Norte 230000 6% 13% 437 229563
López Sur 175000 5% 12% 297,5 174702,5

Tabla de comisiones
Importe
ventas Bonus Comisión
100000 3% 10%
150000 4% 11%
200000 5% 12%
250000 6% 13%
> 250000 7% 14%

En la misma hoja se dispone además de una Tabla de Consultas vertical,


destinada al cálculo de comisiones y bonus. Los tramos son los siguientes.
1. Calcular las comisiones a percibir por cada uno de los vendedores en
función de los tramos señalados.
2. Calcular los bonus percibidos por cada uno de los vendedores, en
función de los tramos señalados.
3. Calcular la remuneración total de cada vendedor como la suma de
comisiones y bonus.
4. Calcular el importe neto de las ventas que le queda a la empresa
después de descontar la remuneración de los vendedores.