You are on page 1of 14

Simulating RIP

Basic RIP Configuration


Configure RIPv2 on all interfaces of all devices in the internal network. Disable auto-
summary.
R4 and R6 should be learning RIP routes from BB3 and BB1 respectively.
Test reachability to all networks and note any problems within the topology.

Configuration
R1:
router rip
version 2
network 150.1.0.0
network 155.1.0.0
no auto-summary
R2:
router rip
version 2
network 150.1.0.0
network 155.1.0.0
network 192.10.1.0
no auto-summary
R3:
router rip
version 2
network 150.1.0.0
network 155.1.0.0
no auto-summary
R4:
router rip
version 2
network 150.1.0.0
network 155.1.0.0
network 204.12.1.0
no auto-summary
R5:
router rip
version 2
network 150.1.0.0
network 155.1.0.0
no auto-summary

R6:
router rip
version 2
network 54.0.0.0
network 150.1.0.0
network 155.1.0.0
no auto-summary
SW1:
ip routing
!
router rip
version 2
network 150.1.0.0
network 155.1.0.0
no auto-summary
SW2:
ip routing
!
router rip
version 2
network 150.1.0.0
network 155.1.0.0
no auto-summary
SW3:
ip routing
!
router rip
version 2
network 150.1.0.0
network 155.1.0.0
no auto-summary
SW4:
ip routing
!
router rip
version 2
network 150.1.0.0
network 155.1.0.0
no auto-summary

RIPv2 Authentication
Configure RIPv2 authentication on the Ethernet link between R2 and BB2.
Use the MD5 key number 1 with a password of <pass>.
R2 should be learning RIP routes from BB2.
Configure clear-text RIP authentication on the segment between R1 and
R6 using the password <pass>
R1:
key chain RIP
key 1
key-string<pass1>
!
interface FastEthernet0/0
ip rip authentication mode text
ip rip authentication key-chain RIP

R2:
key chain RIP
key 1
key-string<pass>
!
interface FastEthernet0/0
ip address 192.10.1.2 255.255.255.0
ip rip authentication mode md5
ip rip authentication key-chain RIP

R6:
key chain RIP
key 1
key-string<pass1>
!
interface FastEthernet0/0.146
ip rip authentication mode text
ip rip authentication key-chain RIP

RIPv2 Split Horizon
Disable split-horizon on R5s connection to the Frame Relay cloud.
Test reachability to all networks and note any changes within the topology.
R5:
interface Serial0/0.1 multipoint
noip split-horizon

RIPv2 Auto-Summary
Enable auto-summary under the RIP process of R4.
Note any changes in the network advertisements that R4 is sending.
SW2:
interface Vlan58
ip rip send version 2
ip rip receive version 2
!
interface Port-channel1
ip rip send version 1
ip rip receive version 1
!
router rip
network 150.1.0.0
network 155.1.0.0
no auto-summary
SW4:
router rip
network 150.1.0.0
network 155.1.0.0
no auto-summary

RIP Send and Receive Versions
Remove the version 2 commands under the RIP processes of SW2 and SW4.
Configure SW2 to send and receive only RIPv2 updates on VLAN 58.
Configure SW2 to send and receive only RIPv1 updates on the link to SW4.
Note any changes in reachability or routing information in the network.
SW2:
interface Vlan58
ip rip send version 2
ip rip receive version 2
!
interface Port-channel1
ip rip send version 1
ip rip receive version 1
!
router rip
network 150.1.0.0
network 155.1.0.0
no auto-summary
SW4:
router rip
network 150.1.0.0
network 155.1.0.0
no auto-summary
Simulating OSPF
OSPF over Broadcast Media
Enable OSPF on all devices using Process-ID 1.
On R1 configure OSPF area 1 on the link to VLAN 146.
On R2 configure OSPF area 51 on the link to VLAN 22.
On R3 configure OSPF area 2 on the link to SW1.
On R4 configure OSPF area 1 on the link to VLAN 146.
On R5 configure OSPF area 3 on the links to VLANs 5 and 58.
On R6 configure OSPF area 1 on the link to VLAN 146, and area 2 on thelink to VLAN
67.
Do not use the network statement under the OSPF process on R1, R2,R3, R4, R5, or
R6.
On SW1 configure OSPF area 2 on all interfaces with an IP addressassigned using
one single network statement.
On SW2 configure OSPF area 3 on interfaces with IP addresses in therange of
155.X.0.0 155.X.127.255 using one single network statement.
On SW3 configure OSPF area 2 on interfaces with IP addresses in therange of
155.X.9.0 155.X.9.255 and 155.X.79.0 155.X.79.255 usingtwo network
statements.
On SW4 configure OSPF area 3 only on interfaces with the exact IPaddresses
155.X.10.10 and 155.X.108.10.
Note any reachability problems throughout the OSPF topology.
R1:
interface FastEthernet0/0
ip ospf 1 area 4
R2:
interface FastEthernet0/0
ip ospf 1 area 51
R3:
interface FastEthernet0/0
ip ospf 1 area 4
!
router ospf 1
router-id 150.1.3.3
R4:
interface FastEthernet0/1
ip ospf 1 area 1
R5:
interface FastEthernet0/0
ip ospf 1 area 3
!
interface FastEthernet0/1
ip ospf 1 area 3
R6:
interface FastEthernet0/0.67
ip ospf 1 area 2
!
interface FastEthernet0/0.146
ip ospf 1 area 1
SW1:
ip routing
!
router ospf 1
network 0.0.0.0 255.255.255.255 area 2
SW2:
ip routing
!
router ospf 1
network 155.1.0.0 0.0.127.255 area 3
SW3:
ip routing
!
router ospf 1
router-id 150.1.9.9
network 155.1.9.0 0.0.0.255 area 2
network 155.1.79.0 0.0.0.255 area 2
SW4:
ip routing
!
router ospf 1
network 155.1.10.10 0.0.0.0 area 3
network 155.1.108.10 0.0.0.0 area 3
OSPF over Non-Broadcast Media
Configure OSPF area 0 on R1, R2, R3, R4, and R5s connections to the
Frame Relay network.
Without modifying the OSPF network type on any of these devices ensure
full reachability is obtained throughout the OSPF domain.
R1:
interface Serial0/0
ip ospf 1 area 0
frame-relay map ip 155.1.0.2 105
frame-relay map ip 155.1.0.3 105
frame-relay map ip 155.1.0.4 105
R2:
interface Serial0/0
ip ospf 1 area 0
frame-relay map ip 155.1.0.1 205
frame-relay map ip 155.1.0.3 205
frame-relay map ip 155.1.0.4 205
R3:
interface Serial1/0
ip ospf 1 area 0
frame-relay map ip 155.1.0.1 305
frame-relay map ip 155.1.0.2 305
frame-relay map ip 155.1.0.4 305
R4:
interface Serial0/0
ip ospf 1 area 0
frame-relay map ip 155.1.0.1 405
frame-relay map ip 155.1.0.2 405
frame-relay map ip 155.1.0.3 405
R5:
interface Serial0/0
ip ospf 1 area 0
!
router ospf 1
neighbor 155.1.0.3
neighbor 155.1.0.1
neighbor 155.1.0.2
neighbor 155.1.0.4
OSPF DR/BDR Election Manipulation
Configure the network so that R6 is elected the OSPF Designated Router
for VLANs 67 and 146.
If R6 goes down R1 should take over the DR status for VLAN 146.
When R6 comes back up it should become the BDR.
Modify the DR/BDR election on the Frame Relay network to ensure that if
R5s connection to the Frame Relay network goes down and comes back
up, full reachability is still maintained.
R1:
interface Serial0/0
ip ospf priority 0
R2:
interface Serial0/0
ip ospf priority 0
R3:
interface Serial1/0
ip ospf priority 0
R4:
interface Serial0/0
ip ospf priority 0
!
interface FastEthernet0/1
ip ospf priority 0
R6:
interface FastEthernet0/0.67
ip ospf priority 255
!
interface FastEthernet0/0.146
ip ospf priority 255
Simulating OSPF with STUB AREA,NSSA, Restricting LSAs
R5:
router ospf 1
area 3 stub no-summary
R3:
router ospf 1
area 2 nssa
R6:
interface Loopback0
shutdown
!
interface FastEthernet0/0.146
shutdown
!
router ospf 1
area 2 nssa
SW1:
router ospf 1
area 2 nssa
SW3:
router ospf 1
area 2 nssa
OSPF Internal Summarization
Configure R5 to advertise a summary route for the VLAN 8 and 10 prefixes as they
are sent into area 0.
This summary should be as specific as possible while still encompassing all
addresses in both subnets.

R5:
router ospf 1
area 3 range 155.1.8.0 255.255.252.0

OSPF Path Selection with Summarization
Configure R3 to originate the summary route 155.X.6.0/23 in order to force traffic
destined to VLAN 7 to transit R6.
If R6s connection to VLAN 146 is down, traffic for VLAN 7 should transit R3.
R3:
router ospf 1
area 2 range 155.1.6.0 255.255.254.0

OSPF External Summarization
Redistribute between RIPv2 and OSPF on R4.
Redistribute between EIGRP and OSPF on R6.
R4 should advertise a single summary route into OSPF for the prefixes learned from
BB3 that has a cost of 50.
R6 should advertise a single summary route into OSPF for the prefixes learned from
BB1 that has a cost of 100, and includes the cost needed to reach R6.
R4:
router ospf 1
router-id 150.1.4.4
summary-address 30.0.0.0 255.252.0.0
summary-address 31.0.0.0 255.252.0.0
redistribute rip metric 50 subnets
!
router rip
redistribute ospf 1 metric 1
R6:
router eigrp 10
redistribute ospf 1 metric 10000 1000 255 1 1500
!
router ospf 1
summary-address 200.0.0.0 255.255.252.0
redistribute eigrp 10 metric 100 metric-type 1 subnets
SW4:
router ospf 1
router-id 150.1.10.10

OSPF Stub Areas
Configure OSPF area 3 so that R5 filters External routes out as they are sent from
area 0 to area3.
Devices in area 3 should still have reachability to routes external to theOSPF domain.

R5:
router ospf 1
area 3 stub
SW2:
router ospf 1
area 3 stub
SW4:
router ospf 1
area 3 stub

OSPF Totally Stubby Areas
Configure OSPF area 3 so that R5 filters Inter-Area and External routes asthey are
sent from
area 0 to area 3.
Devices in area 3 should still have reachability to routes external to theOSPF domain.
R5:
router ospf 1
area 3 stub no-summary

OSPF Not-So-Stubby Areas
Shutdown R6s Loopback0 interface and connection to VLAN 146.
Configure OSPF area 2 so that R3 filters External routes out as they are sent from
area 0 to area2.
R6 should still be allowed to redistribute EIGRP into OSPF.
Note any reachability problems throughout the domain..
R3:
router ospf 1
area 2 nssa
R6:
interface Loopback0
shutdown
!
interface FastEthernet0/0.146
shutdown
!
router ospf 1
area 2 nssa
SW1:
router ospf 1
area 2 nssa
SW3:
router ospf 1
area 2 nssa








Simulating iBGP
Establishing iBGPPeerings
Configure BGP on all internal devices using AS 100.
Create a full mesh of iBGPpeerings between these devices without using their
Loopback interfaces.
Advertise the Loopback0 interfaces of these devices into BGP.
Ensure full reachability to these Loopback0 interfaces from all internal devices.
R1:
router bgp 100
network 150.1.1.0 mask 255.255.255.0
neighbor 155.1.0.2 remote-as 100
neighbor 155.1.0.3 remote-as 100
neighbor 155.1.0.4 remote-as 100
neighbor 155.1.0.5 remote-as 100
neighbor 155.1.58.8 remote-as 100
neighbor 155.1.67.7 remote-as 100
neighbor 155.1.79.9 remote-as 100
neighbor 155.1.108.10 remote-as 100
neighbor 155.1.146.6 remote-as 100
R2:
router bgp 100
network 150.1.2.0 mask 255.255.255.0
neighbor 155.1.0.1 remote-as 100
neighbor 155.1.0.3 remote-as 100
neighbor 155.1.0.4 remote-as 100
neighbor 155.1.0.5 remote-as 100
neighbor 155.1.37.7 remote-as 100
neighbor 155.1.58.8 remote-as 100
neighbor 155.1.79.9 remote-as 100
neighbor 155.1.108.10 remote-as 100
neighbor 155.1.146.6 remote-as 100
R3:
router bgp 100
network 150.1.3.0 mask 255.255.255.0
neighbor 155.1.0.1 remote-as 100
neighbor 155.1.0.2 remote-as 100
neighbor 155.1.0.4 remote-as 100
neighbor 155.1.0.5 remote-as 100
neighbor 155.1.37.7 remote-as 100
neighbor 155.1.58.8 remote-as 100
neighbor 155.1.79.9 remote-as 100
neighbor 155.1.108.10 remote-as 100
neighbor 155.1.146.6 remote-as 100
R4:
router bgp 100
network 150.1.4.0 mask 255.255.255.0
neighbor 155.1.0.1 remote-as 100
neighbor 155.1.0.2 remote-as 100
neighbor 155.1.0.3 remote-as 100
neighbor 155.1.0.5 remote-as 100
neighbor 155.1.58.8 remote-as 100
neighbor 155.1.67.7 remote-as 100
neighbor 155.1.79.9 remote-as 100
neighbor 155.1.108.10 remote-as 100
neighbor 155.1.146.6 remote-as 100
R5:
router bgp 100
network 150.1.5.0 mask 255.255.255.0
neighbor 155.1.0.1 remote-as 100
neighbor 155.1.0.2 remote-as 100
neighbor 155.1.0.3 remote-as 100
neighbor 155.1.0.4 remote-as 100
neighbor 155.1.37.7 remote-as 100
neighbor 155.1.58.8 remote-as 100
neighbor 155.1.79.9 remote-as 100
neighbor 155.1.108.10 remote-as 100
neighbor 155.1.146.6 remote-as 100
R6:
router bgp 100
network 150.1.6.0 mask 255.255.255.0
neighbor 155.1.0.2 remote-as 100
neighbor 155.1.0.3 remote-as 100
neighbor 155.1.0.5 remote-as 100
neighbor 155.1.58.8 remote-as 100
neighbor 155.1.67.7 remote-as 100
neighbor 155.1.79.9 remote-as 100
neighbor 155.1.108.10 remote-as 100
neighbor 155.1.146.1 remote-as 100
neighbor 155.1.146.4 remote-as 100
SW1:
router bgp 100
network 150.1.7.0 mask 255.255.255.0
neighbor 155.1.0.5 remote-as 100
neighbor 155.1.23.2 remote-as 100
neighbor 155.1.37.3 remote-as 100
neighbor 155.1.58.8 remote-as 100
neighbor 155.1.67.6 remote-as 100
neighbor 155.1.79.9 remote-as 100
neighbor 155.1.108.10 remote-as 100
neighbor 155.1.146.1 remote-as 100
neighbor 155.1.146.4 remote-as 100

SW2:
router bgp 100
network 150.1.8.0 mask 255.255.255.0
neighbor 155.1.0.1 remote-as 100
neighbor 155.1.0.2 remote-as 100
neighbor 155.1.0.3 remote-as 100
neighbor 155.1.0.4 remote-as 100
neighbor 155.1.37.7 remote-as 100
neighbor 155.1.58.5 remote-as 100
neighbor 155.1.79.9 remote-as 100
neighbor 155.1.108.10 remote-as 100
neighbor 155.1.146.6 remote-as 100
SW3:
router bgp 100
network 150.1.9.0 mask 255.255.255.0
neighbor 155.1.0.5 remote-as 100
neighbor 155.1.23.2 remote-as 100
neighbor 155.1.37.3 remote-as 100
neighbor 155.1.58.8 remote-as 100
neighbor 155.1.67.6 remote-as 100
neighbor 155.1.79.7 remote-as 100
neighbor 155.1.108.10 remote-as 100
neighbor 155.1.146.1 remote-as 100
neighbor 155.1.146.4 remote-as 100
SW4:
router bgp 100
network 150.1.10.0 mask 255.255.255.0
neighbor 155.1.0.1 remote-as 100
neighbor 155.1.0.2 remote-as 100
neighbor 155.1.0.3 remote-as 100
neighbor 155.1.0.4 remote-as 100
neighbor 155.1.37.7 remote-as 100
neighbor 155.1.58.5 remote-as 100
neighbor 155.1.79.9 remote-as 100
neighbor 155.1.108.8 remote-as 100
neighbor 155.1.146.6 remote-as 100
Simulating EBGP
Establishing EBGP Peerings
BB1 and BB3 are in AS 54.
Configure EBGP peerings between R4 & BB3 and R6 & BB1 using the indirectly
connected links.
Advertise the external links between R4 & BB3 and R6 & BB1 into IGP.
Ensure full reachability to all prefixes learned from AS 54 from all internal devices
when sourcing
traffic from the Loopback0 interfaces.
router eigrp 100
passive-interface FastEthernet0/0
network 204.12.1.0
!
router bgp 100
neighbor 204.12.1.254 remote-as 54
R6:
router eigrp 100
passive-interface Serial0/0
network 54.0.0.0
!
router bgp 100
neighbor 54.1.1.254 remote-as 54

Configuring IP Multicast Routing
PIM Dense Mode
Enable dense-mode multicast delivery on the path between R6 and SW4.
Do not enable PIM on the Frame-Relay cloud.
To test this configuration, configure SW4s VLAN 10 interface to join the multicast
group 224.10.10.10.
Make sure R6 can ping this multicast group.
R4:
No ip multicast-routing
!
No interface FastEthernet 0/1
No ip pim dense-mode
!
No interface Serial 0/1
No ip pim dense-mode
R6:
No ip multicast-routing
!
No interface FastEthernet 0/0.146
No ip pim dense-mode
R5:
No ip multicast-routing
!
No interface Serial 0/1
No ip pim dense-mode
!
No interface FastEthernet 0/0
no ip pim dense-mode

SW2:
No ip multicast-routing distributed
!
interface Vlan 58
ip pim dense-mode
!
interface Port-Channel1
ip pim dense-mode
SW4:
ip multicast-routing
!
interface Port-Channel1
ip pim dense-mode
!
interface Vlan 10
ip igmp join-group 224.10.10.10
ip pim dense-mode





PIM Sparse Mode
Remove the previous PIM Dense Mode configuration and replace it with Sparse
Mode on all
interfaces.
Use R5s Loopback0 interface as the static Rendezvous Point address.
Configure SW4s VLAN 10 interface to join the group 224.20.20.20, andensure that
SW3 can send multicast packets to this segment.
Perform SPT switchover only when the traffic flow exceeds 128Kbps.
R4:
ip multicast-routing
ip pim rp-address 150.1.5.5
!
interface FastEthernet 0/1
ip pim sparse-mode
!
interface Serial 0/1
ip pim sparse-mode
!
interface Serial 0/0.1
no ip pim dense-mode
R5:
ip multicast-routing
ip pim rp-address 150.1.5.5
!
interface Serial 0/1
ip pim sparse-mode
!
interface FastEthernet 0/0
ip pim sparse-mode
!
! Needed to fix RPF check for R5s Loopback0
!
interface Loopback0
ip ospf network point-to-point
R6:
ip multicast-routing
ip pim rp-address 150.1.5.5
!
Interface FastEthernet 0/0.146
ip pim sparse-mode
SW2:
ip multicast-routing
ip pim rp-address 150.1.5.5
!
interface Vlan 58
ip pim sparse-mode
!
interface Port-Channel1
ip pim sparse-mode
SW4:
ip multicast-routing
ip pim rp-address 150.1.5.5
ip pim spt-threshold 128
!
interface Port-Channel1
ip pim sparse-mode
!
interface Vlan 10
ip igmp join-group 224.10.10.10
ip pim sparse-mode




area 3 virtual-link <loopback address of opposite interface>

You might also like