You are on page 1of 15

Mtodo de Proyectos

La financiera mi Banco desea controlar el pago a sus


trabajadores por lo cual le pide a usted pueda
implementar un control de horas trabajadas de esa
manera calcular el pago a sus empleados.
Grupo: 2 Integrantes
Participantes:
-

Microsoft Office 2013

Control de Asistencia - Planilla

EXCEL

Funciones de Bsqueda

Funcin BUSCARV
Sintaxis

BUSCARV(Dato; Tabla; num_col [; ordenado])

Busca el DATO en la primera columna de la Tabla y devuelve el valor de celda


correspondiente de la columna num_col. La Tabla no incluye encabezados. El

argumento ordenado es un valor lgico (opcional), si es verdadero indica que la


primera columna de la tabla esta ordenada y falso sino lo est. Por defecto el
argumento ordenado es VERDADERO, es decir se asume que la primera columna de
la tabla est ordenada.
Si se hace la bsqueda asumiendo que la tabla est ordenada y realmente no lo est,
la funcin BUSCARV devolver un valor incorrecto en la mayora de situaciones. En
caso de no encontrar el valor buscado, se mostrar el mensaje de error: #N/A (not
available) (no disponible) Recomendaciones

Si va a buscar un valor exacto, asegrese de que la primera columna


de la tabla est ordenada o asigne FALSO al argumento ordenado.
Si va a buscar valores aproximados (valor inferior ms cercano) utilice
el argumento ordenado en VERDADERO.
Asigne nombre al rango de la tabla sin incluir encabezados, esto
facilitar la construccin de las frmulas.

Utilizando la funcin BuscarV


1. Abra el Libro Planilla.xls. La hoja Listado contiene una pequea base de datos
de trabajadores. Se ha creado una Lista (Men Datos, Lista, Crear Lista) en
ella.

Hoja Listado
2. Tambin contamos con la hoja Ficha

Hoja Ficha
3. Slo se ingresar el cdigo del trabajador en la celda D4 de la hoja
Ficha y crearemos las frmulas en las celdas D5 hasta D10
4. Asigne el nombre TRABAJADORES al rango A5:G19 de la hoja
Listado
5. Digite C005 en la celda D4 de la hoja Ficha. (Slo para efectos de
prueba)
6. Buscando el APELLIDO. El argumento ordenado es Falso para
que encuentre exactamente el dato de la celda D4 y sino lo
encuentra devuelva un mensaje de error.

= BUSCARV(D4; TRABAJADORES;2;Falso)
7. Buscando el SEXO.

= BUSCARV(D4; TRABAJADORES;3;Falso)
8. Buscando el TIPO.

= BUSCARV(D4; TRABAJADORES;4;Falso)
9. Ud. calcule Condicin, Categora y rea.

Funcin BUSCARH
Sintaxis

BUSCARH(Dato; Tabla; num_fila [; ordenado])

Busca el DATO en la primera fila de la Tabla y devuelve el valor de celda


correspondiente de la fila num_fila. La Tabla no incluye encabezados (los
cuales estaran ubicados a la izquierda de la tabla).
En todos los otros aspectos es igual que la funcin BuscarV.
Luego desarrollaremos ejemplos con esta funcin.

Actividad 1. Aplicando la funcin BuscarV

Objetivo
Emplear la funcin BuscarV para mostrar los datos de la hoja Boleta

Procedimiento
1. En la hoja ControlLaboral, asigne nombre HORAS al rango A6:G20.

Hoja ControlLaboral
A continuacin la hoja Configuracin

Hoja configuracin

Hoja configuracin

2. En la hoja Configuracin:
a. asigne el nombre HMES a la celda C2
b. asigne el nombre PSEGURO a la celda C4
c. asigne el nombre TVARIOS al rango G2:I4
d. asigne el nombre TBONI2 al rango B8:C12
e. asigne el nombre TPAGO al rango B17:C18
3. Crear las frmulas para la hoja ReporteHoras. Para efectos de
prueba ingrese el valor C005 en la celda C4.

Hoja Reporte de horas


4. Ejemplos:
a. En C5 escriba: =BUSCARV(C4; TRABAJADORES; 2;
FALSO)
b. En D7 escriba: =HMES
c. En B11 escriba: =BUSCARV(C4; HORAS; 2; FALSO)
d. En B15 escriba: =SI(B11<HMES; HMES-B11; 0)
e. En B19 escriba: =SI(B11>HMES; B11-HMES; 0)

Funcin COINCIDIR
Devuelve la posicin relativa de un elemento en una lista. No devuelve el
valor de la celda sino su posicin dentro de la tabla. La sintaxis es:

COINCIDIR (Valor_buscado; Tabla; Tipo_de_coinciden

La Tabla se conforma de una sola fila o columna.


Si tipo_de_coincidencia es 1, COINCIDIR encuentra el
mayor valor que es inferior o igual al valor_buscado. Los
valores en el argumento Tabla deben colocarse en orden
ascendente

Si tipo_de_coincidencia es 0, COINCIDIR encuentra el


primer valor que es exactamente igual al valor_buscado.
Los valores en la Tabla pueden estar en cualquier orden.
Si tipo_de_coincidencia es -1, COINCIDIR encuentra el
menor valor que es mayor o igual al valor_buscado. Los
valores de la tabla deben colocarse en orden descendente.
Si se omite tipo_de_coincidencia, se supondr que es 1.

Utilizando COINCIDIR
1. En la hoja ControlLaboral
a. Asigne el nombre DATOHORAS al rango B6:G20
b. Asigne el nombre CODTRAB al rango A6:A20
c. Asigne el nombre MESES al rango B5:G5 2. Abra la
hoja Consulta

Hoja Consulta
3. Para efectos de prueba escriba en la celda D6 el valor C004 y en
D7 escriba Febrero.
4. Determinar la posicin del Codigo del Trabajador. Escriba la
siguiente frmula en la celda E6:

=COINCIDIR(D6;CODTRAB;0)
5. Determinar la posicin del Mes. Escriba la siguiente frmula en la
celda E7

=COINCIDIR(D7; MESES; 0)

Funcin INDICE
Esta funcin permite ubicar y mostrar un elemento de una lista o una tabla
de acuerdo a su posicin de fila y/o columna. La sintaxis es:

= INDICE(Tabla; num_fila; num_columna)

El argumento num_fila se refiere al nmero de fila del rango que desea


mostrar. El argumento num_columna es opcional y se usar si su rango
incluye ms de una columna.
Puede combinar esta funcin junto con COINCIDIR para mejorar la
presentacin de sus datos.

Utilizando la funcin INDICE


1. Active la hoja Consulta

Hoja consulta
2. Ahora vamos a mostrar la cantidad de horas laboradas del
trabajador C004 en el mes de Febrero. Escriba la siguiente frmula
en la celda D9:

=INDICE (DATOHORAS; E6; E7)

Mejorar la presentacin de los resultados


Las funciones de Bsqueda y Referencia vistas son muy tiles para crear
soluciones como consultas de productos, ubicar valores aproximados, etc.
En esta seccin del manual, veremos como mejorar la presentacin de
datos, evitando mensajes de error debido a diversos factores como celdas
en blanco, valores no encontrados, etc.

Funcin ESBLANCO
Esta funcin devuelve VERDADERO si la celda evaluada esta vaca, en
caso contrario devuelve FALSO. La sintaxis es:

= ESBLANCO (CELDA)

Por ejemplo, en la solucin creada en la Hoja ReporteHoras, se


presentan mensajes de error (#N/A) si la celda a buscar (C4} est vaca.
En este caso haremos que se muestra un mensaje Escriba un cdigo si
la celda C4 esta vaca. En caso contrario debe usarle la funcin
BUSCARV que ya tena implementada. La frmula ser:

=SI(ESBLANCO(C4); "Escriba un cdigo";


BUSCARV(C4; TRABAJADORES; 2))

Al dejar la celda C4 vaca se muestra ahora un mensaje personalizado.

Funcin ESNOD
La funcin ESNOD devuelve VERDADERO si el valor de la celda se
refiere al valor de error #N/A (el valor no disponible). En el caso de las
funciones BUSCAR, este error se muestra al no ubicarse al elemento en
la tabla de bsqueda.
Por ejemplo, la frmula para ubicar la categora es:

=BUSCARV(C4;TRABAJADORES;6)
Si usted escribe un cdigo como 0, esta frmula muestra el error #N/A.
Podemos evitar este mensaje de error mediante la funcin ESNOD. Lo
que haremos es usar esta funcin para saber si da como resultado
VERDADERO. Si es Verdadero significa que el cdigo no existe, si es
falso, dicho cdigo existe y debe buscarse con la frmula planteada. La
frmula ser como:

=SI(ESNOD(BUSCARV(C4;TRABAJADORES;6)); "No Ubicado";


BUSCARV(C4;TRABAJADORES;6))

Validacin de datos en
celdas.
La seccin anterior se encargo de controlar los diversos errores que
pueden surgir al usar funciones BUSCAR. Otra estrategia para evitar esos
mensajes de error sera que se controle el ingreso de datos a buscar, por
ejemplo que se ingrese slo cdigos que existan en su tabla, o se limite el
ingreso a nmeros entre un determinado intervalo, etc.

Validacin por Listas


Por ejemplo, se pide que en la celda C4 se limite el ingreso de datos a
cdigos que existan en nuestra tabla de trabajadores. Para realizar esta
accin, debe seguir el procedimiento:
1. Asigne el nombre CODIGO al rango A5:A19 de la hoja Listado.
2. Luego, lleve el indicador a la celda C4 de la hoja ReporteHoras.
3. En el men Datos, seleccione Validacin
4. Observar el siguiente cuadro:

Cuadro Validacin
5. En la lista Permitir: elija LISTA
6. En Origen: escriba el signo IGUAL (=) y el nombre del rango
definido anteriormente. En nuestro caso escriba =CODIGO.
7. Haga clic en Aceptar.
1. Ahora, en la celda D5 se muestra una lista para seleccionar el
cdigo a ubicar.

Celda D5 con validacin de Lista

Quitar una validacin


Si usted desea que su celda ya no tenga opciones de validacin, slo
debe:
1. Seleccione la celda
2. Elija el men Datos, Validacin.
3. En el cuadro Permitir elija Cualquier valor
4. Haga clic en Aceptar.

Validacin por intervalo de nmeros,


Otra forma de validar el ingreso de datos es a travs de controlar que slo
se ingresen valores entre un rango de nmeros. Por ejemplo en la hoja

ControlLaboral deben ingresarse cantidades mayores o iguales que 0 y


menores de 300
1. Seleccione el rango DATOHORAS
2. En el men Datos, ValidacinEn este cuadro se muestra la
configuracin que debe aplicar

Cuadro Validacin
3. Para probar esta opcin, escriba un valor fuera del intervalo
definido. Por ejemplo, escriba 305 y observe el mensaje de error

Celda B6 con validacin de nmero.

Mensajes de Ingreso y de Error.


Incluso, puede definir un mensaje de entrada (mensaje que se muestra al
llevar el indicador sobre la celda validada) o un mensaje de error (mensaje
personalizado que se muestra al ingresar un valor fuera del rango
definido).

Para definir un mensaje entrante.


1. Lleve el indicador a la celda a definir. En nuestro caso a la celda D7
2. Elija el men Datos, Validacin.
3. En la ficha Mensaje entrante, escriba como Ttulo: Seleccionar
Mes.

4. En el Mensaje escriba: Expanda la lista y escoja un mes.


5. Haga clic en Aceptar.
Si lleva el indicador a la celda D7 observe el mensaje:

Mensaje entrante en la celda D7

Para definir un mensaje de error.


1. Lleve el indicador a la celda a definir. En nuestro caso a la celda D7
2. Elija el men Datos, Validacin.
3. En la ficha Mensaje de error, escriba como Ttulo: Consulta de
Horas.
4. En el Mensaje escriba: Error en el ingreso de datos. Escoja un
mes de la lista.
5. Haga clic en Aceptar.
6. En la celda D7 escriba un valor que no corresponda a ningn
nombre de mes.

Mensaje de error personalizado.

Actividad 2. Resolver Boleta de Pago


Objetivo
Utilizando las funciones vistas hasta este momento resuelva la hoja Boleta
de pago. Procedimiento
1. Active la hoja Boleta.

Hoja Boleta
2. Observaciones.
a. La mayora de clculos le resultar familiar. Sin embargo,
aclaramos el clculo del Seguro que ser de 8% de los
ingresos, sin embargo la empresa cubre el seguro de
acuerdo a la tabla TVarios. Por lo tanto slo se descontar
de seguro la aportacin del trabajador (F19)

Preguntas de Repaso
1. Qu diferencias hay entre usar VERDADERO o FALSO en el
ltimo argumento de las funciones BUSCARV y BUSCARH?
2. Qu valor devolver la funcin
=BUSCARV("AZ35";A2:B6;2;FALSO)? Si usa
=BUSCARV("AZ35";A2:B6;2;VERDADERO) que valor ser ahora?
(Use la
siguiente tabla)

Tabla de ejemplo
3. En el libro Costos de Produccin se tiene la tablas:

Hoja1

Hoja2
Considerando las tablas de la figura anterior, en la Hoja2 se desea
hacer una consulta de acuerdo a las siguientes especificaciones:

El Cdigo y las unidades a producir son ingresados por


teclado
La Descripcin y el Porcentaje deben ser buscados de la
Hoja1. La bsqueda debe ser de valores exactos.
De la semana 2 a la 4 se incrementar de acuerdo al
Porcentaje.
Para Hallar el Costo Produccin se debe multiplicar el
Total (celda G11) por el Costo Unidad (valor que debe ser
buscado de la Hoja1) Valide la tabla de acuerdo a las
siguientes especificaciones:

La Descripcin y el Porcentaje nunca deben mostrar errores de tipo #N/A.


Use las funciones ESBLANCO, ESNOD y otras que considere.
Las unidades slo deben aceptar valores enteros entre 250 y
unidades.
El cdigo se debe mostrar en una lista.

550

El cdigo debe ser validado.


Finalmente, personalice los mensajes entrantes y de error para la celda de
las Unidades.
Ejercicio Propuesto 01.

Ejercicio Propuesto