You are on page 1of 8

Belajar mengkonfigurasi basic OSPFv3 diJuniper

(11 juni 2010)

http://iwing.wordpress.com
http://www.ittelkom.ac.id/pinguin

Percobaan ini menggunakan logical router, topology yang digunakan adalah sebagai berikut:

Langkah-langkahnya adalah sebagai berikut:

----------------------------------------------------------------------------------------
Configure R1
----------------------------------------------------------------------------------------
[edit logical-routers R1]
root@iwing#set interfaces lo0.1 family inet address 1.1.1.1
root@iwing#set interfaces fxp1.1 family inet6 address 10::10:1/64
root@iwing#set interfaces fxp2.2 family inet6 address 13::13:1/64
root@iwing#set protocols ospf3 area 0 interface lo0.1 pasive
root@iwing#set protocols ospf3 area 0 interface fxp1.1
root@iwing#set protocols ospf3 area 0 interface fxp2.2
----------------------------------------------------------------------------------------
Configure R2
----------------------------------------------------------------------------------------
[edit logical-routers R2]
root@iwing#set interfaces lo0.2 family inet address 2.2.2.2
root@iwing#set interfaces fxp2.1 family inet6 address 10::10:2/64
root@iwing#set interfaces fxp3.2 family inet6 address 11::11:1/64
root@iwing#set protocols ospf3 area 0 interface lo0.2 pasive
root@iwing#set protocols ospf3 area 0 interface fxp2.1
root@iwing#set protocols ospf3 area 0 interface fxp3.2
----------------------------------------------------------------------------------------
Configure R3
----------------------------------------------------------------------------------------
[edit logical-routers R3]
root@iwing#set interfaces lo0.3 family inet address 3.3.3.3
root@iwing#set interfaces fxp4.1 family inet6 address 11::11:2/64
root@iwing#set interfaces fxp2.3 family inet6 address 12::12:1/64
root@iwing#set protocols ospf3 area 0 interface lo0.3 pasive
root@iwing#set protocols ospf3 area 0 interface fxp4.1
root@iwing#set protocols ospf3 area 0 interface fxp2.3
----------------------------------------------------------------------------------------
Configure R4
----------------------------------------------------------------------------------------
[edit logical-routers R4]
root@iwing#set interfaces lo0.4 family inet address 4.4.4.4
root@iwing#set interfaces fxp1.2 family inet6 address 13::13:2/64
root@iwing#set protocols ospf3 area 0 interface lo0.4 pasive
root@iwing#set protocols ospf3 area 0 interface fxp1.2
----------------------------------------------------------------------------------------
Configure R5
----------------------------------------------------------------------------------------
[edit logical-routers R5]
root@iwing#set interfaces lo0.5 family inet address 5.5.5.5
root@iwing#set interfaces fxp1.3 family inet6 address 12::12:2/64
root@iwing#set protocols ospf3 area 0 interface lo0.5 pasive
root@iwing#set protocols ospf3 area 0 interface fxp1.3

----------------------------------------------------------------------------------------
how to check 1 (run show ospf3 neighbor[logical-router..])
----------------------------------------------------------------------------------------
[edit]
root@iwing# run show ospf3 neighbor logical-router R4
ID Interface State Pri Dead
1.1.1.1 fxp1.2 Full 128 30
Neighbor-address fe80::2aa:0:1e00:104
[edit]
root@iwing# run show ospf3 neighbor logical-router R1
ID Interface State Pri Dead
2.2.2.2 fxp1.1 Full 128 31
Neighbor-address fe80::2aa:0:a00:104
4.4.4.4 fxp2.2 Full 128 32
Neighbor-address fe80::2aa:0:1e00:103
[edit]
root@iwing# run show ospf3 neighbor logical-router R2
ID Interface State Pri Dead
1.1.1.1 fxp2.1 Full 128 32
Neighbor-address fe80::2aa:0:a00:103
3.3.3.3 fxp3.2 Full 128 30
Neighbor-address fe80::2aa:0:1400:106
[edit]
root@iwing# run show ospf3 neighbor logical-router R3
ID Interface State Pri Dead
5.5.5.5 fxp2.3 Full 128 36
Neighbor-address fe80::2aa:0:2800:103
2.2.2.2 fxp4.1 Full 128 39
Neighbor-address fe80::2aa:0:1400:105
[edit]
root@iwing# run show ospf3 neighbor logical-router R5
ID Interface State Pri Dead
3.3.3.3 fxp1.3 Full 128 33
Neighbor-address fe80::2aa:0:2800:104
----------------------------------------------------------------------------------------
how to check 2 (run show route protocol ospf [logical-router..])
----------------------------------------------------------------------------------------
[edit]
root@iwing# run show route protocol ospf logical-router R4

inet.0: 1 destinations, 1 routes (1 active, 0 holddown, 0 hidden)

inet6.0: 8 destinations, 8 routes (8 active, 0 holddown, 0 hidden)


+ = Active Route, - = Last Active, * = Both

10::/64 *[OSPF/10] 00:17:12, metric 2


> to fe80::2aa:0:1e00:104 via fxp1.2
11::/64 *[OSPF/10] 00:17:12, metric 3
> to fe80::2aa:0:1e00:104 via fxp1.2
12::/64 *[OSPF/10] 00:17:12, metric 4
> to fe80::2aa:0:1e00:104 via fxp1.2
ff02::5/128 *[OSPF/10] 00:17:22, metric 1
MultiRecv

[edit]
root@iwing# run show route protocol ospf logical-router R1

inet.0: 1 destinations, 1 routes (1 active, 0 holddown, 0 hidden)

inet6.0: 10 destinations, 11 routes (10 active, 0 holddown, 0 hidden)


+ = Active Route, - = Last Active, * = Both

11::/64 *[OSPF/10] 00:38:10, metric 2


> to fe80::2aa:0:a00:104 via fxp1.1
12::/64 *[OSPF/10] 00:23:44, metric 3
> to fe80::2aa:0:a00:104 via fxp1.1
ff02::5/128 *[OSPF/10] 01:10:20, metric 1
MultiRecv

[edit]
root@iwing# run show route protocol ospf logical-router R2

inet.0: 1 destinations, 1 routes (1 active, 0 holddown, 0 hidden)

inet6.0: 10 destinations, 11 routes (10 active, 0 holddown, 0 hidden)


+ = Active Route, - = Last Active, * = Both

12::/64 *[OSPF/10] 00:23:47, metric 2


> to fe80::2aa:0:1400:106 via fxp3.2
13::/64 *[OSPF/10] 00:19:14, metric 2
> to fe80::2aa:0:a00:103 via fxp2.1
ff02::5/128 *[OSPF/10] 01:10:56, metric 1
MultiRecv

[edit]
root@iwing# run show route protocol ospf logical-router R3

inet.0: 1 destinations, 1 routes (1 active, 0 holddown, 0 hidden)

inet6.0: 10 destinations, 11 routes (10 active, 0 holddown, 0 hidden)


+ = Active Route, - = Last Active, * = Both

10::/64 *[OSPF/10] 00:37:10, metric 2


> to fe80::2aa:0:1400:105 via fxp4.1
13::/64 *[OSPF/10] 00:19:16, metric 3
> to fe80::2aa:0:1400:105 via fxp4.1
ff02::5/128 *[OSPF/10] 01:09:50, metric 1
MultiRecv

[edit]
root@iwing# run show route protocol ospf logical-router R5

inet.0: 1 destinations, 1 routes (1 active, 0 holddown, 0 hidden)

inet6.0: 8 destinations, 8 routes (8 active, 0 holddown, 0 hidden)


+ = Active Route, - = Last Active, * = Both

10::/64 *[OSPF/10] 00:21:42, metric 3


> to fe80::2aa:0:2800:104 via fxp1.3
11::/64 *[OSPF/10] 00:21:42, metric 2
> to fe80::2aa:0:2800:104 via fxp1.3
13::/64 *[OSPF/10] 00:19:23, metric 4
> to fe80::2aa:0:2800:104 via fxp1.3
ff02::5/128 *[OSPF/10] 00:21:52, metric 1
MultiRecv
----------------------------------------------------------------------------------------
how to check 3 (run ping and treceroute [logical-router..])
----------------------------------------------------------------------------------------
[edit]
root@iwing# run ping 12::12:2 logical-router R4 count 4
PING6(56=40+8+8 bytes) 13::13:2 --> 12::12:2
16 bytes from 12::12:2, icmp_seq=0 hlim=61 time=1.740 ms
16 bytes from 12::12:2, icmp_seq=1 hlim=61 time=1.293 ms
16 bytes from 12::12:2, icmp_seq=2 hlim=61 time=1.540 ms
16 bytes from 12::12:2, icmp_seq=3 hlim=61 time=1.726 ms

--- 12::12:2 ping6 statistics ---


4 packets transmitted, 4 packets received, 0% packet loss
round-trip min/avg/max/std-dev = 1.293/1.575/1.740/0.181 ms

[edit]
root@iwing# run traceroute 12::12:2 logical-router R4
traceroute6 to 12::12:2 (12::12:2) from 13::13:2, 30 hops max, 12 byte packets
1 13::13:1 (13::13:1) 0.975 ms 1.255 ms 0.937 ms
2 10::10:2 (10::10:2) 1.661 ms 1.008 ms 0.827 ms
3 11::11:2 (11::11:2) 1.460 ms 1.701 ms 1.195 ms
4 12::12:2 (12::12:2) 1.385 ms 1.130 ms 1.464 ms

[edit]
root@iwing# run ping 13::13:2 logical-router R5 count 4
PING6(56=40+8+8 bytes) 12::12:2 --> 13::13:2
16 bytes from 13::13:2, icmp_seq=0 hlim=61 time=1.619 ms
16 bytes from 13::13:2, icmp_seq=1 hlim=61 time=1.319 ms
16 bytes from 13::13:2, icmp_seq=2 hlim=61 time=1.853 ms
16 bytes from 13::13:2, icmp_seq=3 hlim=61 time=1.300 ms

--- 13::13:2 ping6 statistics ---


4 packets transmitted, 4 packets received, 0% packet loss
round-trip min/avg/max/std-dev = 1.300/1.523/1.853/0.229 ms

[edit]
root@iwing# run traceroute 13::13:2 logical-router R5
traceroute6 to 13::13:2 (13::13:2) from 12::12:2, 30 hops max, 12 byte packets
1 12::12:1 (12::12:1) 1.358 ms 0.876 ms 0.803 ms
2 11::11:1 (11::11:1) 1.461 ms 1.069 ms 0.881 ms
3 10::10:1 (10::10:1) 1.256 ms 1.112 ms 1.796 ms
4 13::13:2 (13::13:2) 1.454 ms 1.244 ms 1.383 ms

----------------------------------------------------------------------------------------
konfigurasi lengkapnya @_@
----------------------------------------------------------------------------------------

root@iwing# show
## Last changed: 2010-06-10 09:49:52 UTC
version 8.3R2.8;
system {
host-name iwing;
root-authentication {
encrypted-password "$1$bd4ySf8Q$EaiiIc24ycXAWCQHKOJCf0"; ## SECRET-DATA
}
services {
ftp;
telnet;
}
syslog {
user * {
any emergency;
}
file messages {
any notice;
authorization info;
}
file interactive-commands {
interactive-commands any;
}
}
}
logical-routers {
R1 {
interfaces {
fxp1 {
unit 1 {
vlan-id 10;
family inet6 {
address 10::10:1/64;
}
}
}
fxp2 {
unit 2 {
vlan-id 30;
family inet6 {
address 13::13:1/64;
}
}
}
fxp3 {
unit 4 {
vlan-id 50;
}
}
lo0 {
unit 1 {
family inet {
address 1.1.1.1/32;
}
}
}
}
protocols {
ospf3 {
area 0.0.0.0 {
interface fxp1.1;
interface lo0.1 {
passive;
}
interface fxp2.2;
}
}
}
}
R2 {
interfaces {
fxp1 {
unit 5 {
vlan-id 60;
}
}
fxp2 {
unit 1 {
vlan-id 10;
family inet6 {
address 10::10:2/64;
}
}
}
fxp3 {
unit 2 {
vlan-id 20;
family inet6 {
address 11::11:1/64;
}
}
}
lo0 {
unit 2 {
family inet {
address 2.2.2.2/32;
}
}
}
}
protocols {
ospf3 {
area 0.0.0.0 {
interface fxp3.2;
interface fxp2.1;
interface lo0.2 {
passive;
}
}
}
}
}
R3 {
interfaces {
fxp2 {
unit 3 {
vlan-id 40;
family inet6 {
address 12::12:1/64;
}
}
}
fxp4 {
unit 1 {
vlan-id 20;
family inet6 {
address 11::11:2/64;
}
}
}
lo0 {
unit 3 {
family inet {
address 3.3.3.3/32;
}
}
}
}
protocols {
ospf3 {
area 0.0.0.0 {
interface fxp4.1;
interface lo0.3 {
passive;
}
interface fxp2.3;
}
}
}
}
R4 {
interfaces {
fxp1 {
unit 2 {
vlan-id 30;
family inet6 {
address 13::13:2/64;
}
}
}
lo0 {
unit 4 {
family inet {
address 4.4.4.4/32;
}
}
}
}
protocols {
ospf3 {
area 0.0.0.0 {
interface fxp1.2;
interface lo0.4 {
passive;
}
}
}
}
}
R5 {
interfaces {
fxp1 {
unit 3 {
vlan-id 40;
family inet6 {
address 12::12:2/64;
}
}
}
lo0 {
unit 5 {
family inet {
address 5.5.5.5/32;
}
}
}
}
protocols {
ospf3 {
area 0.0.0.0 {
interface fxp1.3;
interface lo0.5 {
passive;
}
}
}
}
}
R6 {
interfaces {
fxp5 {
unit 1 {
vlan-id 50;
}
}
lo0 {
unit 6;
}
}
}
}
interfaces {
fxp1 {
vlan-tagging;
}
fxp2 {
vlan-tagging;
}
fxp3 {
vlan-tagging;
}
fxp4 {
vlan-tagging;
}
fxp5 {
vlan-tagging;
}
fxp6 {
vlan-tagging;
}
}

[edit]
root@iwing#
----------------------------------------------------------------------------------------
sekian dulu dan semoga bermanfaat...."salam sedogedoi"
----------------------------------------------------------------------------------------

You might also like