You are on page 1of 8

Configure EtherChannel and HSRP

This lab was written for Cisco Packet Tracer which can be downloaded for free at
https://www.netacad.com/about-networking-academy/packet-tracer/ (requires sign-up) and includes a
.PKA file with the initial network already configured. The lab can also easily be completed using your
own equipment or GNS3.

Instructions
Open the accompanying Packet Tracer .PKA file titled “Configuring EtherChannel and HSRP Lab”
(requires Packet Tracer installed on your PC). Follow the exercises below to complete this lab.

Topology
IP Address Table
Device Interface IP address Subnet Mask
PC-A Ethernet0 172.16.10.10 255.255.255.0
PC-B Ethernet0 172.16.20.10 255.255.255.0
PC-C Ethernet0 172.16.30.10 255.255.255.0
PC-D Ethernet0 172.16.10.20 255.255.255.0
PC-E Ethernet0 172.16.20.20 255.255.255.0
PC-F Ethernet0 172.16.30.20 255.255.255.0
Switch1 VLAN 99 172.16.99.1 255.255.255.0
VLAN 10 172.16.10.1 255.255.255.0
VLAN 20 172.16.20.1 255.255.255.0
Switch2
VLAN 30 172.16.30.1 255.255.255.0
VLAN 99 172.16.99.2 255.255.255.0
Switch3 VLAN 99 172.16.99.3 255.255.255.0
VLAN 10 172.16.10.2 255.255.255.0
VLAN 20 172.16.20.2 255.255.255.0
Switch4
VLAN 30 172.16.30.2 255.255.255.0
VLAN 99 172.16.99.4 255.255.255.0

Objectives
The objectives for this lab are to configure EtherChannel and HSRP to provide redundancy through the
network

Lab Exercises
1) Verify Starting Configurations
2) Configure EtherChannel
3) Configure HSRP
4) Verify HSRP Operation

Lab Starting Conditions


The PC hosts are preconfigured with IP addresses and subnet masks. STP, VLANs, Trunking, and Inter
VLAN routing are already configured as well.

Exercises 1: Verify Starting Configurations


Task 1 – Verify vlan configuration

The switches are already configured for VLANs. Use the show vlan command on each switch to verify
default VLAN and switchport assignments. Verify default VLAN assignments on Switches 2, 3 and 4 in the
same way.
Task 2 – Verify trunking

The switches are already configured for VLAN trunking. Use the show interface trunk command on each
switch to verify default VLAN and switchport assignments. Verify VLAN trunking on Switches 2, 3 and 4
in the same way.

Task 3 – Verify IP routing

Inter VLAN routing is already configured on Switch 2. Use the show ip route command on Switch2 to
verify routing is enabled.
Task 3 – Verify Switch2 is spanning-tree root for all VLANs

On Switch2 issue the show spanning-tree command to examine spanning-tree settings. A partial output
from Switch2 is shown. Switch2 should be the root bridge for all VLANs.
Switch2# show spanning-tree
VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 32769
Address 0004.9A48.1705
This bridge is the root
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Task 4 – Verify spanning-tree priority on Switch4

On Switch4 issue the show spanning-tree command to examine spanning-tree settings. A partial output
from Switch4 is shown. Switch4 should have a lower Root priority than R2 for all VLANs.
Switch4# show spanning-tree
VLAN0001
Spanning tree enabled protocol ieee
Root ID Priority 24577
Address 0004.9A48.1705

Task 5 – Verify connectivity through network

All hosts should be reachable over the network. Use ping to verify that each host is able to access every
other host. Show is successful ping from PC-A to PC-E.

C:\>ping 172.16.20.20

Pinging 172.16.20.20 with 32 bytes of data:

Reply from 172.16.20.20: bytes=32 time<1ms TTL=127


Reply from 172.16.20.20: bytes=32 time<1ms TTL=127
Reply from 172.16.20.20: bytes=32 time<1ms TTL=127
Reply from 172.16.20.20: bytes=32 time<1ms TTL=127

Exercise 2: Configure EtherChannel


There are redundant links between the access layer switches, Switch1 and Switch3, and the Distribution
layer switches, Switch2 and Switch4. However, to prevent loops STP has the redundant links in blocking
mode. To implement load balancing we will configure a PAgP EtherChannel on the redundant links
between the switches.

Task 1 – Configure Switch1

Switch1(config)# interface range fa0/20-21


Switch1(config-if-range)# channel-group 1 mode desirable

Switch1(config)# interface range fa0/22-23


Switch1(config-if-range)# channel-group 2 mode desirable
Task 2 – Configure Switch2

On Switch2 we need to make the port-channel interfaces have the same trunk configurations as the
trunk interfaces so our first step will be to set the trunk encapsulation to dot1q and the mode to
trunking. This step is not necessary on switches 1 and 3 because they only support dot1q encapsulation.

Switch2(config)# interface port-channel 1


Switch2(config-if)# switchport trunk encapsulation dot1q
Switch2(config-if)# switchport mode trunk

Switch2(config)# interface port-channel 2


Switch2(config-if)# switchport trunk encapsulation dot1q
Switch2(config-if)# switchport mode trunk

Now that the port-channels are properly configured the channel group can be applied to the interfaces

Switch2(config)# interface range fa0/20-21


Switch2(config-if-range)# channel-group 1 mode desirable

Switch2(config)# int range fa0/22-23


Switch2(config-if-range)# channel-group 2 mode desirable

Task 3 – Configure Switch3

Switch3(config)# interface range fa0/20-21


Switch3(config-if-range)# channel-group 1 mode desirable

Switch3(config)# interface range fa0/22-23


Switch3(config-if-range)# channel-group 2 mode desirable

Task 4 – Configure Switch4

On Switch4, as with Switch2, we need to make the port-channel interfaces have the same trunk
configurations as the trunk interfaces so our first step will be to set the trunk encapsulation to dot1q
and the mode to trunking.

Switch4(config)# interface port-channel 1


Switch4(config-if)# switchport trunk encapsulation dot1q
Switch4(config-if)# switchport mode trunk

Switch4(config)# interface port-channel 2


Switch4(config-if)# switchport trunk encapsulation dot1q
Switch4(config-if)# switchport mode trunk

Now that the port-channels are properly configured the channel group can be applied to the interfaces

Switch4(config)# interface range fa0/20-21


Switch4(config-if-range)# channel-group 1 mode desirable

Switch4(config)# int range fa0/22-23


Switch4(config-if-range)# channel-group 2 mode desirable
Task 5 – Verify EtherChannel

Each switch should have two Port-Channels, each with two ports. Channels should be Layer2 Up (SU)
and port should be in port-channel (P). The channel-groups on Switch1 are shown. Verify on the other
switches as well.

Exercise 3: Configure HSRP


Currently Switch2 is the only switch configured for Inter-VLAN routing. This leaves Switch2 as our single
point of failure. If Switch2 goes down, no PCs can reach remote networks or other VLANs. To add
redundancy we will configure Inter VLAN routing on Switch4 and then implement HSRP so if Switch1
fails hosts can use Switch2 to access other networks.

Task 1 – Enable Inter VLAN routing on Switch4


Switch4(config)# ip routing

Switch4(config)# interface vlan 10


Switch4(config-if)# ip address 172.16.10.2 255.255.255.0

Switch4(config)# interface vlan 20


Switch4(config-if)# ip address 172.16.20.2 255.255.255.0

Switch4(config)# interface vlan 30


Switch4(config-if)# ip address 172.16.30.2 255.255.255.0

Task 2 - Configure HSRP on Switch2


Switch2(config)# interface vlan 10
Switch2(config-if)# standby 1 ip 172.16.10.254
Switch2(config-if)# standby 1 priority 200
Switch2(config-if)# standby 1 preempt
Switch2(config-if)# interface vlan 20
Switch2(config-if)# standby 1 ip 172.16.20.254
Switch2(config-if)# standby priority 200
Switch2(config-if)# standby 1 preempt

Switch2(config-if)# interface vlan 30


Switch2(config-if)# standby 1 ip 172.16.30.254
Switch2(config-if)# standby priority 200
Switch2(config-if)# standby 1 preempt

Switch2(config-if)# interface vlan 99


Switch2(config-if)# standby 1 ip 172.16.99.254
Switch2(config-if)# standby priority 200
Switch2(config-if)# standby 1 preempt

Task 2 – Configure HSRP on Switch4

Switch4(config)# interface vlan 10


Switch4(config-if)# standby 1 ip 172.16.10.254
Switch4(config-if)# standby 1 preempt

Switch4(config-if)# interface vlan 20


Switch4(config-if)# standby 1 ip 172.16.20.254
Switch4(config-if)# standby 1 preempt

Switch4(config-if)# interface vlan 30


Switch4(config-if)# standby 1 ip 172.16.30.254
Switch4(config-if)# standby 1 preempt

Switch4(config-if)# interface vlan 99


Switch4(config-if)# standby 1 ip 172.16.99.254
Switch4(config-if)# standby 1 preempt

Task 3 – Because our hosts were configured with Switch1 as their default gateway we will need to
change default gateway on all hosts to the virtual gateway address defined in our HSRP configuration of
.254 address of each subnet. The configuration for PC-A is shown. Change the other host default
gateways in the same way.
Exercise 4: Verify HSRP operation
Task 1 – ping from PC-A to a remote PC. Ping should be successful

C:\>ping 172.16.30.10

Pinging 172.16.30.10 with 32 bytes of data:

Reply from 172.16.30.10: bytes=32 time<1ms TTL=127


Reply from 172.16.30.10: bytes=32 time=1ms TTL=127
Reply from 172.16.30.10: bytes=32 time<1ms TTL=127
Reply from 172.16.30.10: bytes=32 time=7ms TTL=127

Send a trace from PC-A to a remote PC to verify packets are routing through Switch2.

C:\>tracert 172.16.30.10

Tracing route to 172.16.30.10 over a maximum of 30 hops:

1 0 ms 0 ms 0 ms 172.16.10.1
2 0 ms 1 ms 1 ms 172.16.30.10

Task 2 – Simulate Switch2 going offline by shutting down all interfaces.


Switch2(config)# interface range fa0/20-23
Switch2(config-if-range)# shut

Task 3 – ping from PC-A to a remote PC again. Ping should again be successful. May take a few
seconds for the failover to Switch4 to take place.
C:\>ping 172.16.30.10

Pinging 172.16.30.10 with 32 bytes of data:

Reply from 172.16.30.10: bytes=32 time<1ms TTL=127


Reply from 172.16.30.10: bytes=32 time=1ms TTL=127
Reply from 172.16.30.10: bytes=32 time<1ms TTL=127

Send a trace from PC-A to a remote PC to verify packets are now routing through Switch4.
C:\>tracert 172.16.30.10

Tracing route to 172.16.30.10 over a maximum of 30 hops:

1 0 ms 0 ms 0 ms 172.16.10.2
2 0 ms 1 ms 1 ms 172.16.30.10

Congratulations! You have completed this lab

You might also like